Setup

Installation

Install KeplerMapper with pip:

pip install kmapper

To install from source:

git clone https://github.com/MLWave/kepler-mapper
cd kepler-mapper
pip install -e .

Dependencies

KeplerMapper requires:

  • Python (>= 2.7 or >= 3.3)
  • NumPy
  • Scikit-learn

Running some of the examples requires:

  • matplotlib
  • bokeh
  • PIL

Visualizations load external resources:

  • Roboto Webfont (Google)
  • D3.js (Mike Bostock)